Security advisories

Here you will find a list of vulnerabilities that have already been found and fixed in Contao. If you think that you have found a security issue in Contao, please report it according to our security policy.

Cross site scripting via HTML attributes in the back end

Date: 2021-08-11
CVE ID: CVE-2021-35955

Description

It is possible for untrusted users to inject malicious code into HTML attributes in the back end, which will be executed both in the element preview (back end) and on the website (front end).

Installations are only affected if there are untrusted back end users who have the rights to modify HTML fields (e.g. TinyMCE).

Thanks to Mikhail Khramenkov from Solar Security Research Team for reporting the issue.

Affected versions

Contao 4.0
Contao 4.1
Contao 4.2
Contao 4.3
Contao 4.4 up to 4.4.55
Contao 4.5
Contao 4.6
Contao 4.7
Contao 4.8
Contao 4.9 up to 4.9.17
Contao 4.10
Contao 4.11 up to 4.11.6

Suggested solution

Update to Contao 4.4.56, 4.9.18 or 4.11.7.

Workaround

Disable all fields that allow HTML for untrusted back end users or disable the login for these users.

More information

https://github.com/contao/contao/security/advisories/GHSA-hr3h-x6gq-rqcp

Back to the overview.