Security advisories

Here you will find a list of vulnerabilities that have already been found and fixed in Contao. If you think that you have found a security issue in Contao, please report it according to our security policy.

Privilege escalation with the form generator

Date: 2021-08-11
CVE ID: CVE-2021-37627

Description

It is possible for untrusted users to gain administrator rights with the form generator.

Installations are only affected if there are untrusted back end users with access to the form generator.

Affected versions

Contao 4.0
Contao 4.1
Contao 4.2
Contao 4.3
Contao 4.4 up to 4.4.55
Contao 4.5
Contao 4.6
Contao 4.7
Contao 4.8
Contao 4.9 up to 4.9.17
Contao 4.10
Contao 4.11 up to 4.11.6

Suggested solution

Update to Contao 4.4.56, 4.9.18 or 4.11.7.

Workaround

Disable the form generator or disable the login for untrusted back end users.

More information

https://github.com/contao/contao/security/advisories/GHSA-hq5m-mqmx-fw6m

Back to the overview.