Security advisories

Here you will find a list of vulnerabilities that have already been found and fixed in Contao.

Viewing unauthorized records in the back end

Date: 2018-12-13
CVE ID: CVE-2018-20028

Description

The vulnerability allows logged in back end users to view records that have not been enabled for them. There are two ways to exploit the vulnerability:

1. If a back end user without page mounts uses the filter menu in the site structure, they will see all pages matching the filter, even though they have not been enabled for them.

2. Through URL manipulation, a back end user can access records in parent view, which have not been enabled for them – e.g. articles of another user or news items of another archive. It is not possible to alter these records though.

Affected versions

Contao 3.5 up to 3.5.36
Contao 4.0
Contao 4.1
Contao 4.2
Contao 4.3
Contao 4.4 up to 4.4.31
Contao 4.5
Contao 4.6 up to 4.6.10

Suggested solution

Update to Contao 3.5.37, 4.4.31 or 4.6.11.

Back to the overview.

Security policy

If you think that you have found a se­cu­ri­ty is­sue in Con­tao, please re­port it ac­cor­ding to our se­cu­ri­ty poli­cy.