Security advisories

Here you will find a list of vulnerabilities that have already been found and fixed in Contao. If you think that you have found a security issue in Contao, please report it according to our security policy.

Cross site scripting in widgets with units

by Leo Feyer

Date: 2023-07-25
CVE ID: CVE-2023-36806

Authenticated users can inject malicious code in widgets with units, which is then executed both in the element preview (back end) and on the website (front end).

Thanks to Christian Pöschl and Fabian Brenner from usd AG for reporting this vulnerability.

Affected versions

Contao 4.0
Contao 4.1
Contao 4.2
Contao 4.3
Contao 4.4
Contao 4.5
Contao 4.6
Contao 4.7
Contao 4.8
Contao 4.9 up to 4.9.41
Contao 4.10
Contao 4.11
Contao 4.12
Contao 4.13 up to 4.13.27
Contao 5.0
Contao 5.1 up to 5.1.9

Suggested solution

Upgrade to Contao 4.9.42, 4.13.28 or 5.1.10.

More information

Show all security advisories